Powershell WMF 5.0 – 5.1 pour windows 7 (32 ou 64) KB3191566

à noter que si vous avez désactivé les services windows dans vos outils d’administration … et bien il faudra l’activer de nouveau le temps de l’insallation de powershell 5.1

https://www.microsoft.com/en-us/download/details.aspx?id=54616

Voulez vous installer la mise à jour suivante
Mise à jour pour windows (KB3191566)

Bon et bien déjà la 5.1 ne s’installe pas sur Windows 7 entreprise 32 bits …

Essayons avec la 5.0 …

Windows PowerShell s’est arrêté avec l’erreur suivante :
The type initializer for ‘System.Management.Automation.Tracing.PSEtwLog’ threw
an exception.

On va essayer d’installer le NET Framework 4.5, il semblerait que ça vienne de là

Et merde le pare-feu de microsoft m’a bloqué (je clic trop vite …)

Access Denied
You don’t have permission to access « http://www.microsoft.com/en-us/download/details.aspx? » on this server.
Reference #18.19281102.1511212408.328ee558

Et oui c’était bien un problème dedu framework .NET, il faut au moins la V 4.5 (pas essayé de mettre d’autres versions…)

Il vous faut donc la Version suivante Win7-KB3134760-x86.msu

AH!! il semblerait que la V 5.1 s’installe maintenant (après avoir installé le .NET 4.5 et la version 5.0 de powershell)

Win7-KB3191566-x86.msu

Nous voilà donc avec une version à jour de powershell (5.1.14409.1005)!!, je vous conseil de faire un update de l’aide pour les utilisateurs de powershell_ISE (Menu Help en haut à droite => update windows powershell help)

$PsVersionTable

Name Value
—- —–
PSVersion 5.1.14409.1005
PSEdition Desktop
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0…}
BuildVersion 10.0.14409.1005
CLRVersion 4.0.30319.17929
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3
SerializationVersion 1.1.0.1

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *